
ERTH 172 / GEOG 172
Spring 2008
Instructor: Brent Hecht

Laboratory 0: “Intro to GIS and ArcGIS”
By Brent Hecht 

Introduction

Welcome to your first GIS lab! The author of this lab finds GIS to be one of the 
interesting and, yes, fun subjects he has taught.  The purpose of this lab is to try to 
inspire in you some of the same energy about GIS, as well as to introduce you to some 
of the fundamentals of ArcGIS.  ArcGIS is the industry-leading GIS program and is the 
software you will use to complete all of your labs in this class.  Weʼll start out with the 
fundamentals, then weʼll get to the good stuff.  

Please remember to read everything in this lab.  All of it is important, except for 
the occasional lame joke.  

Finally, please answer all questions in a Word document.  You will be turning in this 
document at the end of the lab, along with two fancy PDF maps youʼll be making.

Note: The ArcGIS website can be found at http://www.esri.com/products.html

Lab Objectives

Part I

• Learn the fundamentals of the ArcGIS software
• Learn how to turn in assignments
• Explore GIS problem solving
• Begin thinking like a GIS user

Part II

• Have fun with exciting data sets
• Understand how GIS can be used to solve an unbelievable number of problems

Part I
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1. Open ArcMap 9.2

While we speak of ArcGIS as a single product, it is actually a suite of applications.  For 
now, weʼll just be dealing with ArcMap

Unlike in the past, new versions of ArcMap behave exactly like many other Windows 
programs you have used.  For instance, it can be activated simply by going into the start 
menu and choosing All Programs -> ArcGIS -> ArcMap.  Now, wait a second.  It usually 
takes a little while for ArcMap to get its gears up and running.

Press “OK” (Choose “A new empty map”)

2.  Put your USB keychain drive into action

Make a folder on your USB keychain drive called “GIS”, “IHeartGIS”, or whatever else 
you like.  Inside that folder, make a folder called “Lab0”.  Notice I am not putting any 
spaces in the names.  To be safe, itʼs best to never put spaces in the names of folders 
or directories that you plan on using for GIS.  This is a holdover from the days when 
Chuck Norris was on primetime TV.

3. Download a shapefile

Go into a web browser and go to the URL: http://uweb.ucsb.edu/~bhecht/176A/
STATES_Projected.zip.  Save the zip archive to the folder you just created and unzip it 
by right clicking on it, choosing “Extract all...” and follow the instructions.

Just like Microsoft Word uses “.doc” files and Adobe Acrobat has “.pdf” files, GIS 
software packages boast their own file formats.  In fact, ArcGIS supports many types of 
spatial file formats (and there are many).  One of the most popular of these formats is 
the shapefile, or the “.shp” file.  Much of the spatial data you find on the Internet that is 
meant for advanced GIS analysis comes in the shapefile format.  

Calling the shapefile a “file format” is somewhat of a misnomer.  In fact, a “shapefile” is 
a set of at least 3 files (sometimes more), all with the same file name but with different 
extensions.  A file extension is the three or four letter code that follows the period in file 
names.  More specifically, a shape”file” called “STATES_Projected.shp” (like the one 
you downloaded) consists of at least “ STATES_Projected.shp”, “ 
STATES_Projected.shx” and “ STATES_Projected.dbf”.  Weʼll talk about what each file 
does in a little bit.  (For your over-achievers, most shapefiles also come with a .prj file. 
Can you guess what that is for?)

4. Add the shapefile to the map

Back in ArcMap, click on the icon in the standard toolbar that has a “+” on it, as seen 
below:
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Navigate to the the folder you just created and select “STATES_Projected.shp”.  If you 
havenʼt already, youʼll need to connect to your USB key drive folder.   Do this by hitting 
the “Connect to Folder” button (see below) and selecting the key drive.  Next, double-
click on the key drive in the main “Add Data” window and you should see 
“STATES_Projected.shp”.

Viola!  You should see a map displayed in the data frame. Youʼre now officially a GIS 
user!  But weʼre only 0.000001 percent into the good part...

5. Look at the data table

In the Layers pane, right-click on “STATES_Projected” and choose “Open Attribute 
Table”.  Notice that for each state, there is a row.  Each column represents a piece of 
data about each state.  The attribute table is stored in the “.dbf” file of the shapefile.  
The “.shp” file contains the shapes you see in the data frame.  You donʼt have to worry 
about the “.shx”.

If you scroll to the right, youʼll notice that each column in this particular shapefile 
represents U.S. census data about the states.  POP1999 for instance contains the 
population of the state in the year 1999.  Scroll through the columns.  Youʼll be 
impressed at how much data is available from the U.S. Census (So, when 2010 rolls 
around, be sure to fill out those census forms!)
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6. Examine the data

Right-click on the “STATE_NAME” column and choose “Freeze/Unfreeze Column”.  

Now, scroll on over to the AVG_SIZE87 column, which is an attribute  that contains the  
average farm size in each state in 1987, measured in acres. Can you see a pattern in 
the data?  Write it down (Question 1, 5 points).

6. Make a choropleth map

Although weʼll be studying choropleth maps in detail later in the course, youʼve all see 
them before.  You may not have known what theyʼre called, but youʼve seen them. Our 
choropleth map will represent the first time you will have used one of the most important 
basic GIS functions: visualizing data spatially.  Youʼll see how much easier it is to make 
a hypothesis about spatial patterns by using spatial visualization.

Double-click on the “STATES_Projected” layer and choose the “Symbology” tab.  Click 
on “Quantities” and then  “Graduated colors”.  Choose “AVG_SIZE87” from the “Values” 
pop-up box.  Hit “OK”. (see figure below)
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Wahoo! Your first choropleth map!  Be sure to note the values included in each color 
(the fancy word is “class”) displayed below the name of the “STATES_Projected” layer.

Now, was your pattern from question one correct?  What patterns do you see now?  
Make a hypothesis as to what spatial phenomenon might be the cause of these 
patterns.  Hint: Think back to your U.S. history class in high school.  What type of data 
would you need to test your hypothesis?  (Question 2, 10 points)

7.  Explore the data
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Zoom in on Washington, D.C. by choosing the zoom button in the “Tools” toolbar.  Click 
on the “i” button to select the “Identify” tool and click on Washington, D.C.  Scroll down 
in the “Identify” window to see the value for “AVG_SIZE87”.  What do you think that 
value represents? (Questions 3, 5 points)

Zoom back out to the full extent either using the zoom out button or the “Full Extent” 
button in the toolbar.

8. Export a map to PDF

In ArcMap, there are two views: the “Data View” and the “Layout View”. Youʼve been 
working in the “Data View” thus far.  Letʼs branch out to the “Layout View”.  To switch 
views, click the little page icon next to the world icon near the bottom of the data frame. 
(see figure below)
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The “Layout View” is where you can produce a map to output to your fancy GIS 
shenanigans.  While youʼll need to take a cartography course to fully use and 
understand the communicative power of maps, weʼre going to do a lightening fast 
overview in which youʼll learn some good conventions while also getting to know yet 
another of ArcMapʼs feature sets.

Right now, your map is terrible.  Donʼt worry, itʼs not your fault (this time).  In particular, 
hereʼs what your missing (all maps should have all of these):

1) a title
2) an indication of who made it
3) a legend
4) a listing of data sources
5) a scale bar
6) a north arrow

To make a title, weʼll use the “Draw” toolbar, which on most of your computers will be at 
the bottom of your ArcMap window.  If it is not displayed go to the menu bar and choose 
View->Toolbars and make sure “Draw” is checked.  If it is not, select it, and it will 
appear.  It looks like this:
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Click on the “Text Tool” (the icon with the “A”) on it.  

With the “Text Tool” selected, click on your map near where you want your title to 
appear.  Type your title, and press enter.  The title should be as descriptive as possible 
(i.e. “Average Farm Size by State in 1987”). Make the font size bigger and do whatever 
else you like with the title.  You can change the font and font size by using the tools near 
the text tool icon in the Draw toolbar.  Other standard text editing options are also 
available (bolding, color, italics, etc.).  You can also move your title around.  Try double-
clicking on the title text to see what happens.

Next, add some text somewhere on the map that tells the map reader who made the 
map.  For instance, “Mapmaker: Brent Hecht, GIS Nerd/Agriculture Fan”.  Also, tell the 
map reader who provided the data for the map.  In this case, you should write “Data 
source: U.S. Census”.

Now, weʼre going to add a legend (no, not Roger Tomlinson, the father of GIS... the 
other kind of legend). Go to the Insert menu and choose “Legend”.  Follow the wizard.  
Feel free to play around with the settings to make the best darn legend you can.

The legend displayed under the “STATES_Projected” layer (see below) is what ArcMap 
uses to generate the legends in the layout view.  As such, weʼd better make sure itʼs 
correct.  Thereʼs something very “key” (oh yeah, I made that joke) missing from this 
legend... Can you guess what it it?  Prettier colors? Well, maybe.  The error code “-99” 
is included in the values?  (Whoops, did I just give away an answer?  Hate when that 
happens). Well, thatʼs true, but weʼre not going to worry about that for now.  What Iʼm 
looking for here is that all legends should have UNITS!  To add units, click on each class  
(i.e. “369 - 749”) and add the words “Acres”.  Watch what happens to your legend in the 
layout view!

Finally, can you figure out how to add a scale bar and north arrow?  Hint: itʼs very similar 
to adding a legend.  To change the settings of any element in the layout view, try double 
clicking on it.
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Before we go on, remember that layout matters a lot when communicating a map.  You 
have to use a bit of graphic design instinct and/or artistic taste.  Everyone has it;  I do, 
and youʼve seen my style choices.  Donʼt dare give a sloppy map to anyone.  Itʼs like not 
proofreading when turning in a paper to a professional journal or when writing a 
Mothersʼ Day card.  Speaking of which, remember to proofread too! 

When youʼre ready to export your map, go to the File menu and choose “Export Map”.  
Select the folder on your USB drive youʼre using for this lab, choose “PDF” under “Save 
as type:” and type in the map name “Map1.pdf”.  Note that you can also export to tons 
of other formats (JPEG, GIF, TIFF, etc.), including one that even the nerd writing this lab  
doesnʼt recognize.  Click save.  Navigate to the file you just saved, open it, and admire 
your work.  This map will be worth 10 points (Map 1).

9.  Make another choropleth map

Make at least one more choropleth (with a different attribute field) using the skills youʼve 
learned thus far.  Export it as a PDF as in step 8.  This map will be worth 10 points 
(Map 2).  Save it as “Map2.pdf”

10. Save your project

Go to File -> Save to save your project.  Save it under the name “Lab0Project” in your 
“Lab0” folder.  Saving your ArcMap projects will allow you to access your work exactly 
as you left it if need be. 

Part II

1. Introduction to GIS with “cool” data

Unless youʼre as big of a Geography dork as I am, you are probably not too interested 
in farm acreage.  Fortunately, GIS is valuable for examining any spatial data, even data 
extremely relevant to us young folks.  Spatial data is as prevalent in topics not generally 
considered by academia as it is in the more traditional arenas such as environmental 
science, physical geography, urban geography, archaeology, epidemiology, etc.  For 
instance, I have used GIS to examine the spatial distribution of christian contemporary 
music popularity (i.e. christian rock popularity) as well as the change in spatial 
distribution of Dixie Chicks concerts after their falling out with the country music 
establishment (The lead singer made an anti-war remark several days before the 
invasion of Iraq).  

Go to http://uweb.ucsb.edu/~bhecht/176A/dixiechicks.html.  What patterns do you see?  
What conclusions can you make? (Question 4, 5 points).  
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Now, go to http://uweb.ucsb.edu/~bhecht/176A/christianrock.jpg.  What patterns do you 
see?  What was the source of this data?  (Question 5, 5 points).

2. Using your own “cool” data

Knowing fully that what I think is cool differs significantly from that of most of the 
population (I listened to Bon Jovi, Brooks & Dunn, and select Disney tracks while 
preparing the data for this lab),  I decided I wanted you folks to be able to study 
phenomena that you are guaranteed to think are “cool” (I am now slipping into a Ben 
Stein character).  One of the only topics I figured everyone would think is “cool” is your 
friends.

Those of you with Facebook accounts have lots of spatial data about your friends at 
your fingertips.  The only problem is getting that data into ArcMap.  In order to help you 
do this, I have written a Facebook application that returns a shapefile containing data 
about your friendsʼ hometown locations.  Not all your friends will be represented in the 
file, as not all of your friends likely inputted a hometown location or the hometown 
location was not recognized by the georeferencing system that I used.  For me, about 
65-70 percent had valid data.

At the beginning of this lab, you were instructed on how to retrieve your friendsʼ 
hometown locations in the form of a shapefile.  If you donʼt have a Facebook account, 
you downloaded my friendsʼ data (with names removed of course).

Select “New Project” from the “File” menu and add the Facebook shapefile to the new 
project in the same way that you added the “STATES_Projected” shapefile.

3. Change the visualization of your friends

View the attribute table of your Facebook data.  Look at the available fields.  Can you 
think of any other attributes that might be useful for visualization or analysis of this type 
of data? (Question 6, 5 points)

Go to the “Symbology” in the Facebook layer properties window (as you did in part 1 for 
the “STATES_Projected” layer).  Choose the “Categories” section, put “Sex” in the 
“Value Field” and press “Add All Values”, as shown below.
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Now we need to make the size bigger for all of these icons.  Click on the column header 
for labeled “Symbol” (see above).  Choose “Properties for All Symbols...”.   Enter “10” 
into the “Size:” box under “Options.  Press “OK”.

See if you can figure out how to change the colors for “male”, “female” and nothing 
individually.  (Hint: double click on the dot icon next to each value).

Press “OK” to leave the “Layer Properties” window.

4. Add County-Level U.S. Election data

Download a shapefile of county-level U.S. election data from http://uweb.ucsb.edu/
~bhecht/176A/2004Election.zip.  Add this to your ArcGIS project by following the same 
instructions as in part one of this lab.

Note that, for the first time, you have more than one data layer in your project.  Also, you 
will notice that the county polygons might be covering up the Facebook data.  To place 
the Facebook point data on top, click on the title of the Facebook layer and drag it 
above the “USElection” layer. 
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You are now using the famous overlay operation (which dates back to pre-GIS days, in 
the “before” section of the Roger Tomlinson GIS video).  But we havenʼt unlocked the 
full power of overlay quite yet because we have not displayed the election data as a 
choropleth layer. 

4. Displaying the election data

Go to the symbology screen of the “USElection” layer as you did in part 1 of the lab.  
Choose the field “Bush”, which contains the total number of votes for Bush in the 2004 
election per county, for the “Value” field and “Total”, which contains the total number of 
votes per county, for the “Normalization” field.  This will normalize the votes for Bush by 
the total number of votes, thus giving you the percentage per county of Bush 
supporters.

5. Use the overlay to find patterns

You now have a very powerful visualization at your fingertips.  Use the zoom-in and 
zoom-out tools as in part one to investigate the patterns in the political affiliations of the 
counties that are home to your friends.  Discuss the trends you see.  Do your friends 
come from liberal or conservative areas?  Write about this in full detail.  If you feel 
comfortable writing about it, does this reflect your political views? (you will not be 
penalized for not discussing your own views; do so only if you want to). (Question 7, 15 
points)
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Now, what would happen if you had lots of friends all from the same city?  Those of you 
with my data can look at Albany, CA (my hometown), Lincoln, NE, or St. Paul, MN to see 
an example.  Chances are each of you have a similar situation somewhere.  If you 
donʼt, look at a classmateʼs screen who does.  Use the “Identify” tool to investigate this 
phenomenon.  What is the problem using this type of visual analysis with these data 
sets? (Question 8, 5 points)

6. (Optional) Make a map of your friend data

Use the tools you learned in part 1 to make a map of the overlay you just generated.  
Watch what happens when you make a legend with more than one data set.  If you like, 
you can print the map and keep it to show to the friends who helped you make it!  Do 
not turn it in the TAs; thatʼs your private info!

7.  Turn in the lab

First, create a “ZIP” archive of your work.  Create a folder in your “Lab0” folder on your 
flash drive called “[YOURFULLNAME]_Lab0”.  Place the two PDF maps that you 
generated as well as the Word document containing your answers to all eight questions 
in the folder.  Next, right-click on the folder and choose “Send to... -> Compressed 
(zipped) Folder”. 

This is the file you will send to me via e-mail.  Remember to format the subject line 
correctly!
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