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Laboratory 0.5: More Fun with Friend Data

1.  Ready a new ArcGIS project

Open up ArcGIS and choose “A new empty map...”  Add the “STATES_Projected” layer 
and your Facebook data to the data frame.  If you are given a “Geographic Coordinate 
Systems Warning”, donʼt freak out.  Just press the “Close” button for now.  The warning 
is letting you know that the datum used by one layer is different from that of another.  
While this may cause some important errors in other tasks, our current task is at such a 
small spatial scale (that of the continental USA) that the datum mismatch wonʼt affect us 
significantly.  (If you are confused by my use of the word small, please consult http://
en.wikipedia.org/wiki/Scale_%28map%29)

Save your project into a new folder called “Lab0p5” in the “GIS” folder on your USB 
drive by choosing “File->Save” in the main menu bar.  Be sure to save your project as 
frequently as you save any paper youʼve writen in Microsoft Word.  ArcMap will make 
you want to cry without “I forgot to save!” problems, so be smart.

2.  Start editing

Unlike any other program Iʼve ever seen, ArcGIS has an read-only mode (which is the 
mode in which you normally work) and an explicit “Edit” mode.  One reason they 
probably do this is that, on the nerdy end of things, the shapefile is not set up for fast 
and easy editing.  Regardless, itʼs important to become familiar with this operational 
dichotomy.

To access “Edit” mode, weʼll first need to activate the “Editor” toolbar.  Go to the menu 
bar and choose “View->Toolbars->Editor”.  If “Editor” is already checked, do not select it 
again; the check means itʼs already open.  The “Editor” toolbar looks like this (see figure 
below):

Click on the “Editor” menu in the “Editor” toolbar and choose “Start Editing” (see figure 
below):
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In the resulting dialog, you may be presented with two directories and asked which 
directory you wish to edit.  A directory is a fancy nerd word for a folder.  In ArcGIS, you 
can only edit files in one folder (or database) at a time.  Remember what was written in 
the first lab about ArcGIS being unintuitive?  If you are presented with this dialog, 
choose the folder containing the shapefile with your (or my) Facebook data and click 
“OK”.  Regardless whether or not you got the first window asking about folders, you will 
get one that warns you about editing in a different coordinate system than that in which 
the file is stored.  Again, the error is not going to be significant for this task.  Once you 
press “OK”, youʼll find that the rest of the “Editor” toolbar is now available for use.

3. Edit attribute data

Go into the attributes table of your Facebook hometown layer (as you did in lab one).  
Change all the missing values in the “Sex” field into valid “male” or “female” values.  You 
can do this by clicking on each empty cell and entering “male” or “female” into the cell 
(as you would in Excel).  Note that you canʼt change attribute values of a shapefile 
unless you are currently editing the folder in which the shapefile resides.  If you used my  
Facebook data, make up values for every empty “Sex” field.  In the “Editor” toolbar 
under the “Editor” menu, click “Save Edits”.

4.  Add new data points

Many of your friends are likely either not on Facebook or did not enter a hometown 
location on Facebook.  If you want to make a complete map of your friendsʼ hometowns, 
youʼll need to add the missing values manually.  This is, of course, a very common task 
with any spatial data set.  For now, letʼs just add at least 5 friends.  If youʼre using my 
data set, make data for imaginary friends.

In the “Editor” toolbar, make sure “Create New Feature” is selected under the “Task” 
pop-up menu.   Also, open the “Attribute Editor” by clicking the “Attribute” button on the 
far right of the toolbar (see figure below).  Note that the “Attribute” editor from the 
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“Editor” toolbar is different than the attribute table with which you are already familiar.  
They accomplish similar tasks, but are optimized for different situations; one is for one-
by-one editing, the other for massive editing.  Finally, click “Sketch Tool” (see figure 
below), which is located to the left of the “Task” pop-up menu.

Using the “Sketch Tool” click a location on the map where you have a friend that is not 
in your data set.  You have now created a new point!  To edit the attributes of that point, 
use the “Attribute Editor” window and enter the appropriate values (see figure below).  
Donʼt worry about the “RelStatus” field; just enter a “Sex” value of either “male” or 
“female”.  IMPORTANT: make sure that you keep both lowercase.  Youʼll see why in a 
bit.  If youʼre using your own data, be sure to enter names, too!

If you mess up, you can always change the attributes values in the main attributes table 
as you did in step three, or select a point using “Edit Tool” (find it on the “Editor” toolbar 
next to the “Sketch” tool) and change the attribute values.  

Be sure to do this for at least five data points.  Write down the five or more locations you 
added in your Word file (Question 1.1: 10 points)

Finally, choose “Stop Editing” from the “Editor” toolbar.  Be absolutely sure to choose 
“Save Edits” in the resulting dialog box.

5. Split California
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Judging by the amount of “NorCal” and “SoCal” paraphernalia I see walking around 
campus, I know most of you consider Northern California and its southern counterpart to 
be distinctly different regions.  While you probably know your political energies are best 
spent elsewhere, for the moment weʼre going to indulge in the universal California 
fantasy: splitting it in two. 

In the Editor toolbar, choose “Start Editing” and choose the folder that contains the 
“STATES_Projected” shapefile (if necessary). Regardless, make sure the “Target” in the 
“Editor” toolbar is set to “STATES_Projected”.  Also, change the “Task” pop-up menu to 
“Cut Polygon Features” (see figure below).

Now, click on California.  It will be selected.  Zoom in on California so you can make 
your very important split with greater precision.  The best way to do this is to choose the 
“Zoom In” button from the “Standard” toolbar and draw a bounding box around 
California.  The view will then be matched so that the view extent matches the bounding 
box.

Choose the “Sketch Tool” from the “Editor” toolbar as you did previously.  Each time you 
click using this tool, a new vertex will be made in a polyline that will be used to split the 
state in half (see below figure).  Be sure to start in the Pacific Ocean and end clear into 
Nevada.  You must make sure that all parts of the California polygon appear on one side 
of the line or the other.   When you are done with your line, double-click on the last 
vertex and the California polygon will be split in half.  Once youʼre sure youʼre clear on 
the process, go ahead and split the state!   Hint: If you mess up with a vertex or the 
entire split, you can always use the “Edit->Undo” functions.  It will let you “take back” a 
vertex or even the entire split.  Becoming familiar with the Undo command in every 
program (especially ArcGIS) is a great idea.Bre
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Examine at the attribute values of the new Californias by clicking on the “Edit” tool in the 
“Editor” toolbar, selecting each state, and looking in the “Attribute Editor” window.  The 
“Edit” tool is the button to the left of the “Sketch” tool.  Note that both polygons still have 
“California” in the “STATE_NAME” attribute.  Using the “Attribute Editor” window, give 
each of these new states a creative name.

Look at the attribute table again.  Now that weʼve split California in two, there is a huge 
problem with most of the values in the table for the two California rows.  What is this 
problem? (Question 1.2: 10 points)

Save your edits and stop editing.

6. Make separate “male” and “female” layers

Note the “Selection” menu in the main menu bar.  This menu lets you select different 
spatial features based either on their spatial location or their attribute values.  This is 
very useful because, once selected, you can perform operations on a subset of a spatial 
data set.  For now, weʼre going to just deal with the attribute-based capabilities.  Choose 
“Selection->Select by Attribute...” from the main menu bar. Enter this code into the big 
text box at the bottom.  

“Sex” = ‘male’

This field is case-sensitive.  This means that you have to be sure to make certain that 
the case of every letter is exactly as appears below. (Little do you know, youʼve just 
entered your first structured query language (SQL) command).  Make sure the window 
looks exactly as follows:
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Look at the other attributes of the table.  What is another query you could make that 
does not use the “Sex” attribute? (Question 1.3: 5 points)

Hit “OK” and note that all of your (or my) male friends are highlighted.  Right click on 
your Facebook data layer in the “Table of Contents” (a.k.a. “Legend”) pane.  Choose the 
“Selection” submenu and click on “Create Layer From Selected Features” (see figure 
below). 
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Note that this operation does not make a shapefile of the selected data.  It creates an 
imaginary one that references all the data from the original shapefile.  This can be 
convenient for ephemeral analyses, but for now, we want something more stable (plus, 
weʼre learning about spatial data storage!). To create a real shapefile from this 
imaginary one, right-click on the layer you just created and this time choose “Data-
>Export Data...”.  In the subsequent window, be sure to save the exported data to your 
“Lab2” folder and name it “male_friends.shp” by clicking on the “Browse” button as 
shown (see figure below).  Hit “OK” when you are finished.

Finally, remove the original selected layer (the layer should have the name “[YOUR 
FACEBOOK USER ID NUMBER] selected”) by right-clicking on the layer and choosing 
“Remove”.  
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Now, repeat the process (minus answering the question) for your female friends and 
create a layer called “female_friends.shp”.

When you are done, go to the main menu and choose “Selection->Clear Selected 
Features”.

7. Use Spatial Joins to Create Friend Aggregate Data Sets

Now, weʼre going to do a point-to-polygon spatial join (actually, two of them).  Although 
not technically required by the file format, 99.99999 percent of all shapefiles contain a 
single shape type.  In nearly all cases the type is point. polyline, or polygon.  Which of 
the layers in your current data frame are point layers and which are polygon layers?  
Can you think of an example of a polyline (i.e. line-based) feature? Hint: Google Maps is 
full of them!  What is the difference between a line and a polyline? (Question 1.4: 5 
points)

Right-click on the “STATES_Projected” layer and choose “Joins and Relates->Join...”.  
In the first pop-up menu, select “Join data from another layer based on spatial location”.  
In step one, choose “female_friends”.  Finally, click on the browse button (looks the 
same as it did in the step four) and save the file as 
“female_friends_aggregated_by_state.shp” in your “Lab2” folder.  You can ignore the 
rest of the settings; youʼll learn about those in other GIS labs.  Press “OK”.

A new layer called “female_friends_aggregated_by_state” should be added to your data 
frame.  This layer has all the same spatial features and attributes of 
“STATES_Projected”, except a “Count_” field should be added.  This attribute field 
contains the number of points that fell within each polygon of “STATES_Projected”.  In 
other words, it has a count of your female friend hometown locations.  Note that both 
your northern and your sourthern Californias each have their own count!

Repeat the above for the file containing all of your friends (the original shapefile that you 
edited).  Make a choropleth map of the resulting generated shapefile and export it to 
PDF.  Remember all of the steps we performed in lab 1.  Youʼll be turning in this map, so 
name it “map1.pdf”.  This map will be worth 20 points (Map 1: 20 points).

Extra credit: Make more California regions and redo the aggregation.  Hint: try making a 
Central California region and a Mojave region. Be sure to zoom in on California in your 
resulting map, as thatʼs what the focus of this map is.  (Map 1x: 5 points)

8. Think about what you just did

Itʼs always important to put every task you do in these labs in context.  In other words, 
always ask, “Whatʼs the big picture here?”.  To help you practice doing this, categorize 
steps 3 -7 into the two sub-objectives for part one of the lab, as listed at the beginning of 
the lab. (Question 1.5: 10 points)
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